Site powered by WASD and VMS            WASD VMS Web Services

Download Page ... Last revised 18th March 2020 (look for the RECENTs)

Demonstration server: https://wasd.vsm.com.au/

info-WASD Mailing List

New to WASD?  Start here!  (from Install and Config)

Like to establish the integrity of your package?
Check it's MD5 digest against that in this list.
WASD has it's own MD5 digestor but here is a stand-alone one if required.

<major>.<minor>.<tweak>
The versioning of WASD packages follows this schema; < major change > . < minor change > . < tweak and / or bugfix >
So, major and minor changes are desirable at a functionality level (check Significant Changes document), and tweak/bugfix if experiencing a particular (often undesirable) behaviour (commonly at the server level, check /wasd_root/src/httpd/version.h).

 Current Release

WASD1141.ZIP
27-NOV-2019
WASD1141-AXP.ZIP
27-NOV-2019
WASD1141-IA64.ZIP
27-NOV-2019
WASD1141-VAX.ZIP
27-NOV-2019
7.6MB
contents
4.1MB
contents
4.3MB
contents
1.7MB
contents
WASD Version 11.4.1
Version 10 brought a number of significant changes to the WASD installation and runtime environment. Version 11 also adds significant functionality. WASD v11.4.1 cannot be built or linked against HP SSL version 1.4 or earlier. It requires SSL1 version 1.0, VSI SSL111, or the WASD SSL package below.

Check significant changes carefully and in particular when updating ... Updating? Beware!

Release announcement on info-WASD mailing list.

The three other packages, -AXP, -IA64 and -VAX, contain supplementary, pre-compiled object modules for this release.

 
WASD_CUP_1140c.ZIP
07-MAR-2020 RECENT
482kB
contents
WASD Cumulative Update 11.4.0c
This archive provides a source-code supplement (so local C compiler is required) to the most recent formal release (above), providing the latest bug-fixes and behaviour tweaks in advance of the next formal release.
This CUP is functionally equivalent to the v11.4.1 server
but includes later fixes and so also should be applied to the v11.4.1 package.
WASD_CUP_1130g.ZIP
07-MAR-2020 RECENT
722kB
contents
WASD Cumulative Update 11.3.0g
This CUP is functionally equivalent to the v11.4.1 server.
 
OPENSSLWASD111E-AXP.ZIP
18-MAR-2020 RECENT
OPENSSLWASD111E-IA64.ZIP
18-MAR-2020 RECENT
3.8MB
contents
3.6MB
contents
Secure Sockets Layer
This is the latest OpenSSL 1.1.1 supporting TLSv1.3 — see https://www.openssl.org/blog/blog/2018/09/11/release111/
Always use  $ UNZIP -z  to get important installation/update information!
OpenSSL 1.1.1e (17 March 2020) release, specifically to support WASD. 
 
OPENSSLWASD102S-AXP.ZIP
30-JUL-2019
OPENSSLWASD102S-IA64.ZIP
30-JUL-2019
3.5MB
contents
3.2MB
contents
OpenSSL 1.0.2s release stream is no longer supported
https://www.openssl.org/policies/releasestrat.html
and sites should be moving to 1.1.1.
 
OPENSSLWASD100E-VAX.ZIP
24-NOV-2018
1.7MB
contents
The VAX OpenSSL release was marooned at v1.0.0e due to OpenSSL implementation changes requiring native 64 bit arithmetic and long long data type. However, the TLS/SSL versions provided are no longer considered usable by most browsers and so alternative mechanisms (viz. gateways) should be sought to support secure access to VAX/VMS.
 
FCGIPLUS101.ZIP
20-AUG-2005
80kB
contents
FastCGI Application Interface
A persistent interface to applications built using Open Market, Inc's FastCGI specification (https://en.wikipedia.org/wiki/FastCGI). For Alpha (AXP), Itanium (IA64) and VAX. See https://wasd.vsm.com.au/wasd_root/src/fcgi/ for more information.
 
GSOAPRTE104.ZIP
05-DEC-2013
98kB
contents
gSOAP Persistent Scripting
SOAP applications on VMS, see http://gsoaponopenvms.blogspot.com/ can be deployed as shared images using this Run-Time Environment. See https://wasd.vsm.com.auwasd_root/src/gsoap/ for more information. The kit contains Alpha (AXP) and Itanium (IA64) object modules.
 
PERLWASD128.ZIP
18-MAY-2016
330kB
contents
Perl Persistent Scripting
For Alpha (AXP), Itanium (IA64) VMS Ports Perl 5.24, 5.22, 5.20, 5.18 and HP 5.8, along with VAX Perl 5.18 and 5.8. (This is a repackage of v1.2.8 undertaken on 13th November 2016.)
See https://wasd.vsm.com.au/wasd_root/src/perl/ for more information.
VMS Ports Perl at https://sourceforge.net/projects/vmsperlkit/.
 
PHPWASD145.ZIP
02-FEB-2014
52kB
contents
PHP Persistent Scripting
PHP is an almost universally deployed, powerful, cross-platform, HTML-embedded scripting language (http://www.php.net/). This is an Alpha (AXP) and Itanium (IA64) PHP interface for WASD. It uses the Mark Berryman PHP port(s) which must be obtained separately. See the description in https://wasd.vsm.com.au/wasd_root/src/php/ for further information.

Mark Berryman's PHP Ports
https://www.theberrymans.com/php_kits/
These kits are more complete and up-to-date than those provided by HP, and are always in-development. Any feedback most welcome (even just "worked a treat!") to Mark Berryman at mark@theberrymans.com.

 
PYRTE1112.ZIP
30-JUL-2017
148kB
contents
Python Persistent Scripting
Python is a portable, interpreted, interactive, object-oriented programming language popular for both standalone and Web applications (http://www.python.org/). A persistent scripting RTE for WASD is now available for the Python for OpenVMS 2.7.2 or later port by Jean-François Piéronne available from http://www.vmspython.org/ (also see the VMS Python Wiki at http://www.vmspython.org/ for general information and many demonstrations). This RTE is suitable for both Alpha (AXP) and Itanium (IA64) platforms. See https://wasd.vsm.com.au/wasd_root/src/python/ for further information.

 Other Packages

ALAMODE113B.ZIP
03-DEC-2018
ALAMODE113B-AXP.ZIP
03-DEC-2018
ALAMODE113B-IA64.ZIP
03-DEC-2018
ALAMODE113B-VAX.ZIP
03-DEC-2018
673kB
contents
127kB
contents
139kB
contents
51kB
contents
à la mode suitable for WASD v11.4.n and v11.3.n
A browser-based WASD server monitor usable from all modern browsers. This screenshot gives a bit of a feel of the application, or a live demonstration courtesy of DECUServe, while readmore.html in the source directory provides detailed information.

NOTE: There are packages of à la mode for earlier versions of WASD.

 
DCLINABOX150.ZIP
19-NOV-2016
DCLINABOX150-AXP.ZIP
19-NOV-2016
DCLINABOX150-IA64.ZIP
19-NOV-2016
DCLINABOX150-VAX.ZIP
19-NOV-2016
142kB
contents
71kB
contents
72kB
contents
31kB
contents
DCLinabox
A browser-based VT102 Terminal Emulator allowing login to a hosting system. Requires WASD v10.1 or later and a modern browser. Based on WebSocket communication. Further information at https://wasd.vsm.com.au/wasd_root/src/dclinabox/readmore.html, some screenshots provide an idea of the look and feel, and a live demonstration is available courtesy of DECUServe.
 
HYPERSPIXX310.ZIP
06-FEB-2018
1.8MB
contents
hyperSPI++
The basic hyperSPI available in the WASD package, plus additional report items, plus more sophisticated graphics. Read more. Version 3 is suitable for Alpha, Itanium ($GETRMI API) and VAX. Should be suitable for WASD, OSU, and CSWS (VMS Apache). hyperSPI++ requires DECC 6.n or 7.n and MMS/MMK to build. (Note: the VAX DECC 6.n currently bug-checks during compilation.)
Author: Jean-François Piéronne (jf.pieronne@gmail.com).
 
INTRUSPECT100.ZIP
13-FEB-2017
INTRUSPECT100-AXP.ZIP
13-FEB-2017
INTRUSPECT100-IA64.ZIP
13-FEB-2017
INTRUSPECT100-VAX.ZIP
13-FEB-2017
192kB
contents
85kB
contents
87kB
contents
37kB
contents
INTRUspect
A browser-based VMS intrusion database monitor. It should run as a CGI script under VMS Apache (SWS), OSU and WASD, and be usable from all modern browsers. The overview readmore.html in the source directory provides detailed information.
 
MONDESI620.ZIP
08-APR-2018
MONDESI620-AXP.ZIP
08-APR-2018
MONDESI620-IA64.ZIP
08-APR-2018
MONDESI620-VAX.ZIP
08-APR-2018
455kB
contents
121kB
contents
125kB
contents
51kB
contents
MonDeSi
A browser-based VMS system monitor. It should run as a CGI script under VMS Apache (SWS), OSU and WASD, and be usable from all modern browsers. This screenshot gives a bit of a feel of the application, or a live demonstration (limited to top-process, no per-process) courtesy of DECUServe, while readmore.html in the source directory provides detailed information. Previous versions did not support VAX.
 
SOYMAIL183.ZIP
26-JUL-2017
SOYMAIL183-AXP.ZIP
26-JUL-2017
SOYMAIL183-IA64.ZIP
26-JUL-2017
SOYMAIL183-VAX.ZIP
26-JUL-2017
1.4MB
contents
743kB
contents
677kB
contents
304kB
contents
soyMAIL, Web access to VMS Mail
Overview:  [PDF]  [HTML]
Installation and Administration:  [PDF]  [HTML]
On-line user Help:  https://wasd.vsm.com.au/cgi-bin/soymail?help 
Latest release notes:  https://wasd.vsm.com.au/wasd_root/src/soymail/release_notes.txt 
 
WASDOC110.ZIP
30-JUL-2019
WASDOC110-AXP.ZIP
30-JUL-2019
WASDOC110-IA64.ZIP
30-JUL-2019
WASDOC110-VAX.ZIP
30-JUL-2019
317kB
contents
270kB
contents
277kB
contents
114kB
contents
wasDOC – document authoring and processing system
Used for generating WASD documentation; rationale and full document.
For use at the command-line and in scripting. It employs a plain-text editor and markup directives to generate integrated HTML documentation.

Suitable for VMS Apache, OSU and a standard element of the WASD package.
(And does not need to be added to WASD v11.4.)

 
wCME has been withdrawn due to Let's Encrypt™ retiring ACME v1
A replacement supporting ACME v2 is in field test to be released in due course.
wCME and Let's Encrypt v1 service will continue to work (sorta) during 2020.
WCME200.ZIP
30-JAN-2019
WCME200-111-AXP.ZIP
30-JAN-2019
WCME200-111-IA64.ZIP
30-JAN-2019
WCME200-102-AXP.ZIP
30-JAN-2019
WCME200-102-IA64.ZIP
30-JAN-2019
317kB
contents
821kB
contents
775kB
contents
595kB
contents
651kB
contents
wCME, Certificate Management Environment for Let's Encrypt
"The objective ... is to make it possible to set up an HTTPS server and have it automatically obtain a browser-trusted certificate, without any human intervention [and at no cost]."   https://letsencrypt.org/
 
Archive "I'm sure that used to work before!"

 Mirrors

USA   ftp://ftp.process.com/vms-freeware/wasd/ Hunter Goatley & Process Software
http://www.process.com/
 
USA   https://www.glaver.org/ftp/vms-freeware/wasd/
ftp://ftp.glaver.org/vms-freeware/wasd/
Terry Kennedy
https://www.glaver.org/
 

Archives in this directory have been generated with a VMS ZIPper.
 
You need at least version 5.2, check: $ UNZIP -h
Contents may be listed: $ UNZIP -l archive.ZIP
Contents may be CRC checked: $ UNZIP -t archive.ZIP
Installation and other information: $ UNZIP -z archive.ZIP
UNZIP full release (e.g. wasd_root/src...): $ SET DEFAULT device:[000000]
$ UNZIP archive.ZIP
UNZIP update (e.g. src/...): $ SET DEFAULT WASD_ROOT:[000000]
$ UNZIP archive.ZIP
Need (the latest) UNZIP? ftp://ftp.process.com/vms-freeware/unzip.alpha_exe
ftp://ftp.process.com/vms-freeware/unzip.ia64_exe
ftp://ftp.process.com/vms-freeware/unzip.vax_exe
*PC-based browsers might best access the above two links
using a "Save Link As ..." or "Save Target As ..." dialog
(usually right-click on link)
Main INFO-ZIP site: http://www.info-ZIP.org/

 Mark G. Daniel
 Mark.Daniel@vsm.com.au
 A pox on the houses of all spammers. Make that two poxes.
 Trouble contacting me?